I’ve spent hours, days maybe even weeks now fighting various SharePoint 2013 workflow manager issues over the past year. It seems in my opinion that Workflow Manager is that one component that once it’s working, you just leave it alone! After working with Microsoft and rebuilding it a few months ago and knowing for certain it was happy, it was to my dismay that I created a site collection, attempted to register the workflow service as I do often do,

[box] Register-SPWorkflowService –SPSite “http://myawesomesite” –WorkflowHostUri “https://myworkflowserver.my.domain:12290” -force[/box]
and was greeted with some lovely red text letting me know that it wasn’t gonna happen.
[box type=”warning”] Register-SPWorkflowService : The HTTP request has timed out after 200000 milliseconds. [/box]
 
My first thought was it was just a fluke, but after created a couple other sites and after having the same issue figured better do some digging.
The error didn’t look like any of the ones I’d normally seen when the Workflow Manager was failing. Lucky for me a second set of eyes noticed that the Service Bus service was not running.So after restarting the Service Bus service all was well again. Yay! Quick and easy fix. Hopefully this will help you in the case that you know your Workflow Manager is configured and has been working and you didn’t do anything crazy to it since the last time it worked. 🙂

Happy SharePointing.

(1918)

7 thoughts on “Register-SPWorkflowService timing out

  1. My friend, you are a lifesaver!

    I had this problem and don’t know how many hours I would have burned trying to figure out what’s wrong.

    Thank you!!!!!!!

  2. Thank you so much! Turns out the 3 bus services that are run via sp#### credentials had to be started and all my SP email notifications “popped” and worked correctly afterwards.
    Your article saved me a ton of time … thanks again!

  3. “Service Bus Gateway” was indeed stopped. However, it will not start. It hangs in “starting” for awhile and then it aborts with an unknown exception.

    Anyone solved this issue before?

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.