Month: January 2014

Register-SPWorkflowService timing out

I’ve spent hours, days maybe even weeks now fighting various SharePoint 2013 workflow manager issues over the past year. It seems in my opinion that Workflow Manager is that one component that once it’s working, you just leave it alone! After working with Microsoft and rebuilding it a few months ago and knowing for certain it was happy, it was to my dismay that I created a site collection, attempted to register the workflow service as I do often do, Register-SPWorkflowService –SPSite “http://myawesomesite” –WorkflowHostUri “https://myworkflowserver.my.domain:12290” -force and was greeted with some lovely red text letting me know that it wasn’t gonna happen. Register-SPWorkflowService : The HTTP request has timed out after 200000 milliseconds.   My first thought was it was just a fluke, but after created a couple other sites and after having the same issue figured better do some digging. The error didn’t look like any of the ones I’d normally seen when the Workflow Manager was failing. Lucky for me a second set of eyes noticed that the Service Bus service was not running.So after restarting the Service Bus service all was well again. Yay! Quick and easy fix. Hopefully this will help you in the case that you know your Workflow Manager is configured and has been working and you didn’t do anything crazy to it since the last time it worked. 🙂 Happy SharePointing....

Read More

New year, new blogging platform for 2014.

Happy New Year everyone! I’m looking forward to 2014 and hope and pray that it’ll be a blessed one for everyone. Like most everyone else I’ve got a few resolutions for 2014 and one of those was to move “back” to WordPress as my blogging solution. Now before you get the pitchforks and start rioting, let me give some context and explain why.

Read More

Twitter Posts